<!doctype html>
<html lang="en-US">
<head><meta charset="UTF-8">
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>
    
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="profile" href="https://gmpg.org/xfn/11">

	
		<!-- Begin Flex Tag -->
	<script async src="https://powerad.ai/script.js"></script>
	<!-- End Flex tag -->

    <script data-mrf-script="garda" data-mrf-dt="1" data-mrf-host="bc.marfeelcache.com" data-mrf-ct="article" src="https://bc.marfeelcache.com/statics/marfeel/gardac-sync.js" data-cfasync="false"></script>
<title>NHL Rumors: A College UFA Goalie ... Pending UFAs Who May Not Be Back - NHL Rumors</title>

<!-- This site is optimized with the Yoast SEO Premium plugin v13.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="A college free agent goaltender who is still unsigned. Looking at some pending NHL free agents who may not be back next season."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="A college free agent goaltender who is still unsigned. Looking at some pending NHL free agents who may not be back next season." />
<meta name="twitter:title" content="NHL Rumors: A College UFA Goalie ... Pending UFAs Who May Not Be Back - NHL Rumors" />
<meta name="twitter:image" content="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14121168_168383719_lowres.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mynhltraderumors.com/#organization","name":"Medium Large, LLC","url":"https://mynhltraderumors.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://mynhltraderumors.com/#logo","inLanguage":"en-US","url":"https://s22929.pcdn.co/wp-content/uploads/2019/09/ML_logo_200x200.png","width":200,"height":200,"caption":"Medium Large, LLC"},"image":{"@id":"https://mynhltraderumors.com/#logo"}},{"@type":"WebSite","@id":"https://mynhltraderumors.com/#website","url":"https://mynhltraderumors.com/","name":"NHL Rumors","inLanguage":"en-US","description":"NHL Rumors. Your Source for NHL Trade Rumors, Injury Updates, and Fantasy News.","publisher":{"@id":"https://mynhltraderumors.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://mynhltraderumors.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/#primaryimage","inLanguage":"en-US","url":"https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14121168_168383719_lowres.jpg","width":640,"height":427,"caption":"Looking at some pending UFAs who may not be back next seasons"},{"@type":"WebPage","@id":"https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/#webpage","url":"https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/","name":"NHL Rumors: A College UFA Goalie ... Pending UFAs Who May Not Be Back - NHL Rumors","isPartOf":{"@id":"https://mynhltraderumors.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/#primaryimage"},"datePublished":"2020-03-31T15:58:01+00:00","dateModified":"2020-03-31T16:10:41+00:00","description":"A college free agent goaltender who is still unsigned. Looking at some pending NHL free agents who may not be back next season.","potentialAction":[{"@type":"ReadAction","target":["https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/"]}]},{"@type":"NewsArticle","@id":"https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/#article","isPartOf":{"@id":"https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/#webpage"},"author":{"@id":"https://mynhltraderumors.com/#/schema/person/87e35a680ee2bee8de357019913e7397"},"headline":"NHL Rumors: A College UFA Goalie &#8230; Pending UFAs Who May Not Be Back","datePublished":"2020-03-31T15:58:01+00:00","dateModified":"2020-03-31T16:10:41+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/#webpage"},"publisher":{"@id":"https://mynhltraderumors.com/#organization"},"image":{"@id":"https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/#primaryimage"},"keywords":"Corey Perry,Dallas Stars,Dan Hamhuis,Detroit Red Wings,Jimmy Howard,John Lethemon,Justin Williams,Mikko Koivu,Minnesota Wild,Nashville Predators,Patrick Marleau,Pittsburgh Penguins,Winnipeg Jets","articleSection":"NHL Free Agents,NHL Rumors","inLanguage":"en-US","copyrightYear":"2020","copyrightHolder":{"@id":"https://mynhltraderumors.com/#organization"}},{"@type":["Person"],"@id":"https://mynhltraderumors.com/#/schema/person/87e35a680ee2bee8de357019913e7397","name":"Mark Easson","image":{"@type":"ImageObject","@id":"https://mynhltraderumors.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/6200c5d195992240a5a2a54307618f6b?s=96&d=mm&r=g","caption":"Mark Easson"},"sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//mynhltraderumors.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="NHL Rumors &raquo; Feed" href="https://mynhltraderumors.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="NHL Rumors &raquo; Comments Feed" href="https://mynhltraderumors.com/comments/feed/" />
			<link rel="preload" href="https://s22929.pcdn.co/wp-content/plugins/powerkit/assets/fonts/powerkit-icons.woff" as="font" type="font/woff" crossorigin>
					<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s22929.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='powerkit-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/assets/css/powerkit.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://s22929.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://s22929.pcdn.co/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css'  href='https://s22929.pcdn.co/wp-content/plugins/post-views-counter/css/frontend.css?ver=1.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-author-box-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/author-box/public/css/public-powerkit-author-box.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-basic-elements-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/basic-elements/public/css/public-powerkit-basic-elements.css?ver=2.1.0' type='text/css' media='screen' />
<link rel='stylesheet' id='powerkit-coming-soon-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/coming-soon/public/css/public-powerkit-coming-soon.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-content-formatting-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/content-formatting/public/css/public-powerkit-content-formatting.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-сontributors-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/contributors/public/css/public-powerkit-contributors.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-facebook-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/facebook/public/css/public-powerkit-facebook.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-featured-categories-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/featured-categories/public/css/public-powerkit-featured-categories.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-inline-posts-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/inline-posts/public/css/public-powerkit-inline-posts.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-instagram-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/instagram/public/css/public-powerkit-instagram.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-justified-gallery-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/justified-gallery/public/css/public-powerkit-justified-gallery.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-lightbox-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/lightbox/public/css/public-powerkit-lightbox.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-opt-in-forms-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/opt-in-forms/public/css/public-powerkit-opt-in-forms.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-pinterest-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/pinterest/public/css/public-powerkit-pinterest.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-scroll-to-top-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/scroll-to-top/public/css/public-powerkit-scroll-to-top.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-share-buttons-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/share-buttons/public/css/public-powerkit-share-buttons.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-slider-gallery-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/slider-gallery/public/css/public-powerkit-slider-gallery.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-social-links-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/social-links/public/css/public-powerkit-social-links.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-table-of-contents-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/table-of-contents/public/css/public-powerkit-table-of-contents.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-twitter-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/twitter/public/css/public-powerkit-twitter.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='powerkit-widget-about-css'  href='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/widget-about/public/css/public-powerkit-widget-about.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='yop-public-css'  href='https://s22929.pcdn.co/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public-6.1.4.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://s22929.pcdn.co/wp-content/themes/spotlight/style.css?ver=1567886839' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://s22929.pcdn.co/wp-content/themes/spotlight-child/style.css?ver=1574634455' type='text/css' media='all' />
<link rel='stylesheet' id='searchwp-live-search-css'  href='https://s22929.pcdn.co/wp-content/plugins/searchwp-live-ajax-search/assets/styles/style.css?ver=1.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://s22929.pcdn.co/wp-content/plugins/tablepress/css/default.min.css?ver=1.11' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>
/* <![CDATA[ */
var csco_mega_menu = {"rest_url":"https:\/\/mynhltraderumors.com\/wp-json\/csco\/v1\/menu-posts"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var objectL10n = {"yopPollParams":{"urlParams":{"ajax":"https:\/\/mynhltraderumors.com\/wp-admin\/admin-ajax.php","wpLogin":"https:\/\/mynhltraderumors.com\/admin-ml\/?redirect_to=https%3A%2F%2Fmynhltraderumors.com%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":""},"reCaptchaV2Invisible":{"siteKey":""}},"captchaParams":{"imgPath":"https:\/\/mynhltraderumors.com\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"https:\/\/mynhltraderumors.com\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Poll","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your vote"},"resultsParams":{"singleVote":"vote","multipleVotes":"votes","singleAnswer":"answer","multipleAnswers":"answers"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public-6.1.4.min.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://mynhltraderumors.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mynhltraderumors.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s22929.pcdn.co/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://mynhltraderumors.com/?p=65848' />
<link rel="alternate" type="application/json+oembed" href="https://mynhltraderumors.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmynhltraderumors.com%2Fnhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back%2F2020%2F03%2F31%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mynhltraderumors.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmynhltraderumors.com%2Fnhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back%2F2020%2F03%2F31%2F&#038;format=xml" />
			<meta property="fb:pages" content="104680719604205" />
							<meta property="ia:markup_url" content="https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/?ia_markup=1" />
				<link rel="amphtml" href="https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/amp/">      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://mynhltraderumors.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '337b365d-5242-4a7c-86f7-22dff95e39d9';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "MyNHLtraderumors.com Notifications";
oneSignal_options['welcomeNotification']['message'] = "Thanks for Subscribing! You will now get periodic messages and news.";
oneSignal_options['welcomeNotification']['url'] = "https://mynhltraderumors.com";
oneSignal_options['path'] = "https://s22929.pcdn.co/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.31ca14f2-9a64-44ce-b1fb-164017f55430";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<link rel="icon" href="https://s22929.pcdn.co/wp-content/uploads/2015/12/cropped-mynhltrlogo-150x150.jpg" sizes="32x32" />
<link rel="icon" href="https://s22929.pcdn.co/wp-content/uploads/2015/12/cropped-mynhltrlogo-300x300.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s22929.pcdn.co/wp-content/uploads/2015/12/cropped-mynhltrlogo-300x300.jpg" />
<meta name="msapplication-TileImage" content="https://s22929.pcdn.co/wp-content/uploads/2015/12/cropped-mynhltrlogo-300x300.jpg" />
		<style type="text/css" id="wp-custom-css">
			.entry-content h1,
.entry-header h1,
.entry-content h2,
.entry-header h2,
.entry-content h3,
.entry-header h3,
.entry-content h4,
.entry-header h4,
.entry-content h5,
.entry-header h5,
.entry-content h6,
.entry-header h6 {
    margin-bottom: .75rem;
    font-family: inherit;
    font-weight: 500;
    line-height: 1;
    color: #000000;
    word-wrap: break-word;
}

.entry-content h1,
.entry-header h1 {
    font-size: 2.25rem !important;
}

.entry-content h2,
.entry-header h2 {
    font-size: 1.5rem;
}

.entry-content h3,
.entry-header h3 {
    font-size: 1.25rem;
}

.entry-content h4,
.entry-header h4 {
    font-size: 1.25rem;
}

.entry-content h5,
.entry-header h5 {
    font-size: 1.25rem;
}

.entry-content h6,
.entry-header h6 {
    font-size: 1rem;
}


@media (min-width: 1020px) {
    .content-area {
        flex: 1;
    }
}		</style>
		<style id="kirki-inline-styles">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</style>
    <script data-cfasync='false' src="https://static.thenationnetwork.com/js/jquery.waypoints.min.js"></script>
	<script data-cfasync='false' src="/ad_config.js/"></script>
    <script data-cfasync='false' src="https://static.thenationnetwork.com/js/ads/sites/shared_rtk.js"></script>

    <script language="javascript" src="https://cdn.rhombusads.com/js/rh.min.js" id="rhscript" siteid="1024613"></script>

<!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-58151006-3"></script>

    <script>
        window.dataLayer = window.dataLayer || [];
        function gtag(){dataLayer.push(arguments);}
        gtag('js', new Date());

        gtag('config', 'UA-58151006-3');
    </script>

<!-- Marfeel -->
	
	    <script data-cfasync='false' data-mrf-script="garda" data-mrf-dt="1" data-mrf-host="bc.marfeelcache.com" src="https://bc.marfeelcache.com/statics/marfeel/gardac-sync.js"></script>


    	
<!-- Taboola -->

        <script type="text/javascript">
            !function (e, f, u) {

                e.async = 1;
                e.src = u;
                f.parentNode.insertBefore(e, f);
            }(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/mediumlarge-network/loader.js');
        </script>
    
    
    	
<!-- Termly -->
	
<script>
  (function () {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://app.termly.io/embed.min.js';
    s.id = 'b7268dd1-bd74-4e25-a9c6-57db5caf86ca';
    s.setAttribute("data-name", "termly-embed-banner");
    var x = document.getElementsByTagName('script')[0];
    x.parentNode.insertBefore(s, x);
  })();
</script>

<!-- Mailchimp -->
	
<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/f9af44add02d86f7af4343c9c/4eb731edad030d1d3e7243dfe.js");</script>	

<!-- Mark Stuff -->

<script type="application/javascript" src="https://ced.sascdn.com/tag/3265/smart.js" async></script>
<script type="application/javascript">
    var sas = sas || {};
    sas.cmd = sas.cmd || [];
    sas.cmd.push(function() {
        sas.setup({ networkid: 3265, domain: "https://www15.smartadserver.com", async: true });
    });
    sas.cmd.push(function() {
        sas.call("onecall", {
            siteId: 337393,
            pageId: 1182186,
            formats: [
                 { id: 71430 }
                ,{ id: 73807 }
                ,{ id: 71427 }
                ,{ id: 77934 }
                ,{ id: 71428 }
            ],
            target: ''
        });
    });
</script>
	
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3515913239267445",
          enable_page_level_ads: true
     });
</script>


<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158788755-13";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-158788755-13']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'mynhltraderumors.com']);
_gaq.push(['f._setDomainName', 'mynhltraderumors.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_noads',3]);
_gaq.push(['e._setCustomVar',2,'t','120',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod29',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_noads',3]);
_gaq.push(['f._setCustomVar',2,'domain','mynhltraderumors.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 182912;
var ezdomain = 'mynhltraderumors.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":182912,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"c40ff48d-2370-4d7c-691a-8067398c679a","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":9,"serverid":"3.229.122.42:31172","state":"VA","t_epoch":1585711445,"template_id":120,"time_on_site_visit":0,"url":"https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/","user_id":0,"word_count":1133,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script src="//www.ezojs.com/ezoic/ezd.js" defer async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_182912=" + new Date().getTime() + "|c40ff48d-2370-4d7c-691a-8067398c679a|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>

<body data-rsssl=1 class="post-template-default single single-post postid-65848 single-format-standard wp-embed-responsive header-default navbar-sticky-enabled navbar-smart-enabled sticky-sidebar-enabled stick-to-bottom block-align-enabled">

	<div class="site-overlay"></div>

	<div class="offcanvas">

		<div class="offcanvas-header cs-bg-navbar-dark">

			
			<nav class="navbar navbar-offcanvas">

									<a class="navbar-brand" href="https://mynhltraderumors.com/" rel="home">
						<img src="https://s22929.pcdn.co/wp-content/uploads/2020/01/nhlrumors.jpg"  alt="NHL Rumors" >					</a>
					
				<button type="button" class="toggle-offcanvas button-round">
					<i class="cs-icon cs-icon-x"></i>
				</button>

			</nav>

			
		</div>

		<aside class="offcanvas-sidebar">
			<div class="offcanvas-inner">
				<div class="widget widget_nav_menu cs-d-lg-none"><div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-24229" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24229"><a href="https://mynhltraderumors.com/nhl-rumors/">Rumors</a></li>
<li id="menu-item-24232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24232"><a href="https://mynhltraderumors.com/nhl-trades/">Trades</a></li>
<li id="menu-item-34889" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34889"><a href="https://mynhltraderumors.com/nhl-injuries/">Injuries</a></li>
<li id="menu-item-36154" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36154"><a href="#">Teams</a>
<ul class="sub-menu">
	<li id="menu-item-37402" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37402"><a href="https://mynhltraderumors.com/tag/anaheim-ducks/">Anaheim Ducks</a></li>
	<li id="menu-item-37404" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37404"><a href="https://mynhltraderumors.com/tag/arizona-coyotes/">Arizona Coyotes</a></li>
	<li id="menu-item-37407" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37407"><a href="https://mynhltraderumors.com/tag/boston-bruins/">Boston Bruins</a></li>
	<li id="menu-item-37408" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37408"><a href="https://mynhltraderumors.com/tag/buffalo-sabres/">Buffalo Sabres</a></li>
	<li id="menu-item-37411" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37411"><a href="https://mynhltraderumors.com/tag/calgary-flames/">Calgary Flames</a></li>
	<li id="menu-item-37413" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37413"><a href="https://mynhltraderumors.com/tag/carolina-hurricanes/">Carolina Hurricanes</a></li>
	<li id="menu-item-37415" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37415"><a href="https://mynhltraderumors.com/tag/chicago-blackhawks-trade-rumors-news-injuries/">Chicago Blackhawks</a></li>
	<li id="menu-item-37416" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37416"><a href="https://mynhltraderumors.com/tag/colorado-avalanche/">Colorado Avalanche</a></li>
	<li id="menu-item-37418" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37418"><a href="https://mynhltraderumors.com/tag/columbus-blue-jackets/">Columbus Blue Jackets</a></li>
	<li id="menu-item-37421" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37421"><a href="https://mynhltraderumors.com/tag/dallas-stars/">Dallas Stars</a></li>
	<li id="menu-item-37423" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37423"><a href="https://mynhltraderumors.com/tag/detroit-red-wings/">Detroit Red Wings</a></li>
	<li id="menu-item-37425" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37425"><a href="https://mynhltraderumors.com/tag/edmonton-oilers-trade-rumors-news-injuries/">Edmonton Oilers</a></li>
	<li id="menu-item-37427" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37427"><a href="https://mynhltraderumors.com/tag/florida-panthers/">Florida Panthers</a></li>
	<li id="menu-item-37428" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37428"><a href="https://mynhltraderumors.com/tag/los-angeles-kings-trade-rumors-news-injuries/">Los Angeles Kings</a></li>
	<li id="menu-item-37430" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37430"><a href="https://mynhltraderumors.com/tag/minnesota-wild/">Minnesota Wild</a></li>
	<li id="menu-item-37432" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37432"><a href="https://mynhltraderumors.com/tag/montreal-canadiens-trade-rumors-news-injuries/">Montreal Canadiens</a></li>
	<li id="menu-item-37435" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37435"><a href="https://mynhltraderumors.com/tag/nashville-predators/">Nashville Predators</a></li>
	<li id="menu-item-37437" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37437"><a href="https://mynhltraderumors.com/tag/new-jersey-devils/">New Jersey Devils</a></li>
	<li id="menu-item-37439" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37439"><a href="https://mynhltraderumors.com/tag/new-york-islanders/">New York Islanders</a></li>
	<li id="menu-item-37441" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37441"><a href="https://mynhltraderumors.com/tag/new-york-rangers/">New York Rangers</a></li>
	<li id="menu-item-37443" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37443"><a href="https://mynhltraderumors.com/tag/ottawa-senators/">Ottawa Senators</a></li>
	<li id="menu-item-37445" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37445"><a href="https://mynhltraderumors.com/tag/philadelphia-flyers/">Philadelphia Flyers</a></li>
	<li id="menu-item-37447" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37447"><a href="https://mynhltraderumors.com/tag/phoenix-coyotes/">Phoenix Coyotes</a></li>
	<li id="menu-item-37449" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37449"><a href="https://mynhltraderumors.com/tag/pittsburgh-penguins/">Pittsburgh Penguins</a></li>
	<li id="menu-item-37451" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37451"><a href="https://mynhltraderumors.com/tag/san-jose-sharks/">San Jose Sharks</a></li>
	<li id="menu-item-37452" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37452"><a href="https://mynhltraderumors.com/tag/st-louis-blues/">St. Louis Blues</a></li>
	<li id="menu-item-37455" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37455"><a href="https://mynhltraderumors.com/tag/tampa-bay-lightning/">Tampa Bay Lightning</a></li>
	<li id="menu-item-37457" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37457"><a href="https://mynhltraderumors.com/tag/toronto-maple-leafs-trade-rumors-news-injuries/">Toronto Maple Leafs</a></li>
	<li id="menu-item-37459" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37459"><a href="https://mynhltraderumors.com/tag/vancouver-canucks/">Vancouver Canucks</a></li>
	<li id="menu-item-55609" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55609"><a href="https://mynhltraderumors.com/tag/vegas-golden-knights/">Vegas Golden Knights</a></li>
	<li id="menu-item-37461" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37461"><a href="https://mynhltraderumors.com/tag/washington-capitals/">Washington Capitals</a></li>
	<li id="menu-item-37463" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37463"><a href="https://mynhltraderumors.com/tag/winnipeg-jets/">Winnipeg Jets</a></li>
</ul>
</li>
<li id="menu-item-37539" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-37539"><a href="https://mynhltraderumors.com/top-nhl-prospects/">Prospects</a>
<ul class="sub-menu">
	<li id="menu-item-37540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37540"><a href="https://mynhltraderumors.com/top-nhl-prospects/anaheim-ducks/">Anaheim Ducks</a></li>
	<li id="menu-item-37558" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37558"><a href="https://mynhltraderumors.com/top-nhl-prospects/arizona-coyotes/">Arizona Coyotes</a></li>
	<li id="menu-item-37557" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37557"><a href="https://mynhltraderumors.com/top-nhl-prospects/boston-bruins/">Boston Bruins</a></li>
	<li id="menu-item-37556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37556"><a href="https://mynhltraderumors.com/top-nhl-prospects/buffalo-sabres/">Buffalo Sabres</a></li>
	<li id="menu-item-37555" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37555"><a href="https://mynhltraderumors.com/top-nhl-prospects/calgary-flames/">Calgary Flames</a></li>
	<li id="menu-item-37575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37575"><a href="https://mynhltraderumors.com/top-nhl-prospects/carolina-hurricanes/">Carolina Hurricanes</a></li>
	<li id="menu-item-37574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37574"><a href="https://mynhltraderumors.com/top-nhl-prospects/chicago-blackhawks/">Chicago Blackhawks</a></li>
	<li id="menu-item-37573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37573"><a href="https://mynhltraderumors.com/top-nhl-prospects/colorado-avalanche/">Colorado Avalanche</a></li>
	<li id="menu-item-37572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37572"><a href="https://mynhltraderumors.com/top-nhl-prospects/columbus-blue-jackets/">Columbus Blue Jackets</a></li>
	<li id="menu-item-37571" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37571"><a href="https://mynhltraderumors.com/top-nhl-prospects/dallas-stars/">Dallas Stars</a></li>
	<li id="menu-item-37590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37590"><a href="https://mynhltraderumors.com/top-nhl-prospects/detroit-red-wings/">Detroit Red Wings</a></li>
	<li id="menu-item-37589" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37589"><a href="https://mynhltraderumors.com/top-nhl-prospects/edmonton-oilers/">Edmonton Oilers</a></li>
	<li id="menu-item-37588" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37588"><a href="https://mynhltraderumors.com/top-nhl-prospects/florida-panthers/">Florida Panthers</a></li>
	<li id="menu-item-37587" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37587"><a href="https://mynhltraderumors.com/top-nhl-prospects/los-angeles-kings/">Los Angeles Kings</a></li>
	<li id="menu-item-37586" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37586"><a href="https://mynhltraderumors.com/top-nhl-prospects/minnesota-wild/">Minnestota Wild</a></li>
	<li id="menu-item-37611" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37611"><a href="https://mynhltraderumors.com/top-nhl-prospects/montreal-canadiens/">Montreal Canadiens</a></li>
	<li id="menu-item-37610" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37610"><a href="https://mynhltraderumors.com/top-nhl-prospects/nashville-predators/">Nashville Predators</a></li>
	<li id="menu-item-37607" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37607"><a href="https://mynhltraderumors.com/top-nhl-prospects/new-jersey-devils/">New Jersey Devils</a></li>
	<li id="menu-item-37609" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37609"><a href="https://mynhltraderumors.com/top-nhl-prospects/new-york-islanders/">New York Islanders</a></li>
	<li id="menu-item-37608" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37608"><a href="https://mynhltraderumors.com/top-nhl-prospects/new-york-rangers/">New York Rangers</a></li>
	<li id="menu-item-37627" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37627"><a href="https://mynhltraderumors.com/top-nhl-prospects/ottawa-senators/">Ottawa Senators</a></li>
	<li id="menu-item-37626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37626"><a href="https://mynhltraderumors.com/top-nhl-prospects/philadelphia-flyers/">Philadelphia Flyers</a></li>
	<li id="menu-item-37625" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37625"><a href="https://mynhltraderumors.com/top-nhl-prospects/phoenix-coyotes/">Phoenix Coyotes</a></li>
	<li id="menu-item-37624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37624"><a href="https://mynhltraderumors.com/top-nhl-prospects/pittsburgh-penguins/">Pittsburgh Penguins</a></li>
	<li id="menu-item-37646" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37646"><a href="https://mynhltraderumors.com/top-nhl-prospects/san-jose-sharks/">San Jose Sharks</a></li>
	<li id="menu-item-37623" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37623"><a href="https://mynhltraderumors.com/top-nhl-prospects/st-louis-blues/">St. Louis Blues</a></li>
	<li id="menu-item-37643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37643"><a href="https://mynhltraderumors.com/top-nhl-prospects/tampa-bay-lightning/">Tampa Bay Lightning</a></li>
	<li id="menu-item-37642" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37642"><a href="https://mynhltraderumors.com/top-nhl-prospects/toronto-maple-leafs/">Toronto Maple Leafs</a></li>
	<li id="menu-item-37641" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37641"><a href="https://mynhltraderumors.com/top-nhl-prospects/vancouver-canucks/">Vancouver Canucks</a></li>
	<li id="menu-item-37640" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37640"><a href="https://mynhltraderumors.com/top-nhl-prospects/washington-capitals/">Washington Capitals</a></li>
	<li id="menu-item-37639" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37639"><a href="https://mynhltraderumors.com/top-nhl-prospects/winnipeg-jets/">Winnipeg Jets</a></li>
</ul>
</li>
<li id="menu-item-37183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37183"><a href="https://mynhltraderumors.com/nhl-rankings/">Rankings</a></li>
<li id="menu-item-43380" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-43380"><a href="#">Schedules</a>
<ul class="sub-menu">
	<li id="menu-item-43381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43381"><a href="https://mynhltraderumors.com/nhl-schedules/anaheim-ducks-schedule/">Anaheim Ducks</a></li>
	<li id="menu-item-43382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43382"><a href="https://mynhltraderumors.com/nhl-schedules/arizona-coyotes-schedule/">Arizona Coyotes</a></li>
	<li id="menu-item-43383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43383"><a href="https://mynhltraderumors.com/nhl-schedules/boston-bruins-schedule/">Boston Bruins</a></li>
	<li id="menu-item-43384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43384"><a href="https://mynhltraderumors.com/nhl-schedules/buffalo-sabres-schedule/">Buffalo Sabres</a></li>
	<li id="menu-item-43385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43385"><a href="https://mynhltraderumors.com/nhl-schedules/calgary-flames-schedule/">Calgary Flames</a></li>
	<li id="menu-item-43386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43386"><a href="https://mynhltraderumors.com/nhl-schedules/carolina-hurricanes-schedule/">Carolina Hurricanes</a></li>
	<li id="menu-item-43387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43387"><a href="https://mynhltraderumors.com/nhl-schedules/chicago-blackhawks-schedule/">Chicago Blackhawks</a></li>
	<li id="menu-item-43388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43388"><a href="https://mynhltraderumors.com/nhl-schedules/colorado-avalanche-schedule/">Colorado Avalanche</a></li>
	<li id="menu-item-43389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43389"><a href="https://mynhltraderumors.com/nhl-schedules/columbus-blue-jackets-schedule/">Columbus Blue Jackets</a></li>
	<li id="menu-item-43390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43390"><a href="https://mynhltraderumors.com/nhl-schedules/dallas-stars-schedule/">Dallas Stars</a></li>
	<li id="menu-item-43391" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43391"><a href="https://mynhltraderumors.com/nhl-schedules/detroit-red-wings-schedule/">Detroit Red Wings</a></li>
	<li id="menu-item-43392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43392"><a href="https://mynhltraderumors.com/nhl-schedules/edmonton-oilers-schedule/">Edmonton Oilers</a></li>
	<li id="menu-item-43393" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43393"><a href="https://mynhltraderumors.com/nhl-schedules/florida-panthers-schedule/">Florida Panthers</a></li>
	<li id="menu-item-43394" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43394"><a href="https://mynhltraderumors.com/nhl-schedules/los-angeles-kings-schedule/">Los Angeles Kings</a></li>
	<li id="menu-item-43395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43395"><a href="https://mynhltraderumors.com/nhl-schedules/minnesota-wild-schedule/">Minnesota Wild</a></li>
	<li id="menu-item-43396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43396"><a href="https://mynhltraderumors.com/nhl-schedules/new-jersey-devils-schedule/">New Jersey Devils</a></li>
	<li id="menu-item-43397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43397"><a href="https://mynhltraderumors.com/nhl-schedules/new-york-islanders-schedule/">New York Islanders</a></li>
	<li id="menu-item-43398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43398"><a href="https://mynhltraderumors.com/nhl-schedules/new-york-rangers-schedule/">New York Rangers</a></li>
	<li id="menu-item-43399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43399"><a href="https://mynhltraderumors.com/nhl-schedules/ottawa-senators-schedule/">Ottawa Senators</a></li>
	<li id="menu-item-43400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43400"><a href="https://mynhltraderumors.com/nhl-schedules/philadelphia-flyers-schedule/">Philadelphia Flyers</a></li>
	<li id="menu-item-43401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43401"><a href="https://mynhltraderumors.com/nhl-schedules/pittsburgh-penguins-schedule/">Pittsburgh Penguins</a></li>
	<li id="menu-item-43402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43402"><a href="https://mynhltraderumors.com/nhl-schedules/san-jose-sharks-schedule/">San Jose Sharks</a></li>
	<li id="menu-item-43403" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43403"><a href="https://mynhltraderumors.com/nhl-schedules/st-louis-blues-schedule/">St. Louis Blues</a></li>
	<li id="menu-item-43404" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43404"><a href="https://mynhltraderumors.com/nhl-schedules/tampa-bay-lightning-schedule/">Tampa Bay Lightning</a></li>
	<li id="menu-item-43405" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43405"><a href="https://mynhltraderumors.com/nhl-schedules/toronto-maple-leafs-schedule/">Toronto Maple Leafs</a></li>
	<li id="menu-item-43406" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43406"><a href="https://mynhltraderumors.com/nhl-schedules/vancouver-canucks-schedule/">Vancouver Canucks</a></li>
	<li id="menu-item-43407" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43407"><a href="https://mynhltraderumors.com/nhl-schedules/washington-capitals-schedule/">Washington Capitals</a></li>
	<li id="menu-item-43408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43408"><a href="https://mynhltraderumors.com/nhl-schedules/winnipeg-jets-schedule/">Winnipeg Jets</a></li>
</ul>
</li>
<li id="menu-item-37182" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-37182"><a href="https://mynhltraderumors.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-64539" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-64539"><a href="https://mynhltraderumors.com/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-64598" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64598"><a href="https://mynhltraderumors.com/about/">About</a></li>
	<li id="menu-item-64538" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64538"><a href="https://mynhltraderumors.com/terms-of-service/">Terms of Service</a></li>
	<li id="menu-item-64597" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64597"><a href="https://mynhltraderumors.com/contact/">Contact</a></li>
</ul>
</li>
</ul></div></div>
							</div>
		</aside>
	</div>

<div id="page" class="site">

	
	<div class="site-inner">

		
		<header id="masthead" class="site-header">

			
			

<nav class="navbar navbar-primary">

	
	<div class="navbar-wrap  cs-bg-navbar-dark">

		<div class="navbar-container">

			<div class="navbar-content">

						<button type="button" class="navbar-toggle-offcanvas toggle-offcanvas  cs-d-lg-none">
			<i class="cs-icon cs-icon-menu"></i>
		</button>
					<a class="navbar-brand" href="https://mynhltraderumors.com/" rel="home">
				<img src="https://s22929.pcdn.co/wp-content/uploads/2020/01/nhlrumors.jpg"  alt="NHL Rumors" >			</a>
			<ul id="menu-header-menu-1" class="navbar-nav  cs-navbar-nav-submenu-dark"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24229"><a href="https://mynhltraderumors.com/nhl-rumors/">Rumors</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24232"><a href="https://mynhltraderumors.com/nhl-trades/">Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34889"><a href="https://mynhltraderumors.com/nhl-injuries/">Injuries</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36154"><a href="#">Teams</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37402"><a href="https://mynhltraderumors.com/tag/anaheim-ducks/">Anaheim Ducks</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37404"><a href="https://mynhltraderumors.com/tag/arizona-coyotes/">Arizona Coyotes</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37407"><a href="https://mynhltraderumors.com/tag/boston-bruins/">Boston Bruins</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37408"><a href="https://mynhltraderumors.com/tag/buffalo-sabres/">Buffalo Sabres</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37411"><a href="https://mynhltraderumors.com/tag/calgary-flames/">Calgary Flames</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37413"><a href="https://mynhltraderumors.com/tag/carolina-hurricanes/">Carolina Hurricanes</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37415"><a href="https://mynhltraderumors.com/tag/chicago-blackhawks-trade-rumors-news-injuries/">Chicago Blackhawks</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37416"><a href="https://mynhltraderumors.com/tag/colorado-avalanche/">Colorado Avalanche</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37418"><a href="https://mynhltraderumors.com/tag/columbus-blue-jackets/">Columbus Blue Jackets</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37421"><a href="https://mynhltraderumors.com/tag/dallas-stars/">Dallas Stars</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37423"><a href="https://mynhltraderumors.com/tag/detroit-red-wings/">Detroit Red Wings</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37425"><a href="https://mynhltraderumors.com/tag/edmonton-oilers-trade-rumors-news-injuries/">Edmonton Oilers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37427"><a href="https://mynhltraderumors.com/tag/florida-panthers/">Florida Panthers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37428"><a href="https://mynhltraderumors.com/tag/los-angeles-kings-trade-rumors-news-injuries/">Los Angeles Kings</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37430"><a href="https://mynhltraderumors.com/tag/minnesota-wild/">Minnesota Wild</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37432"><a href="https://mynhltraderumors.com/tag/montreal-canadiens-trade-rumors-news-injuries/">Montreal Canadiens</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37435"><a href="https://mynhltraderumors.com/tag/nashville-predators/">Nashville Predators</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37437"><a href="https://mynhltraderumors.com/tag/new-jersey-devils/">New Jersey Devils</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37439"><a href="https://mynhltraderumors.com/tag/new-york-islanders/">New York Islanders</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37441"><a href="https://mynhltraderumors.com/tag/new-york-rangers/">New York Rangers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37443"><a href="https://mynhltraderumors.com/tag/ottawa-senators/">Ottawa Senators</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37445"><a href="https://mynhltraderumors.com/tag/philadelphia-flyers/">Philadelphia Flyers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37447"><a href="https://mynhltraderumors.com/tag/phoenix-coyotes/">Phoenix Coyotes</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37449"><a href="https://mynhltraderumors.com/tag/pittsburgh-penguins/">Pittsburgh Penguins</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37451"><a href="https://mynhltraderumors.com/tag/san-jose-sharks/">San Jose Sharks</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37452"><a href="https://mynhltraderumors.com/tag/st-louis-blues/">St. Louis Blues</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37455"><a href="https://mynhltraderumors.com/tag/tampa-bay-lightning/">Tampa Bay Lightning</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37457"><a href="https://mynhltraderumors.com/tag/toronto-maple-leafs-trade-rumors-news-injuries/">Toronto Maple Leafs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37459"><a href="https://mynhltraderumors.com/tag/vancouver-canucks/">Vancouver Canucks</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55609"><a href="https://mynhltraderumors.com/tag/vegas-golden-knights/">Vegas Golden Knights</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37461"><a href="https://mynhltraderumors.com/tag/washington-capitals/">Washington Capitals</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-37463"><a href="https://mynhltraderumors.com/tag/winnipeg-jets/">Winnipeg Jets</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-37539"><a href="https://mynhltraderumors.com/top-nhl-prospects/">Prospects</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37540"><a href="https://mynhltraderumors.com/top-nhl-prospects/anaheim-ducks/">Anaheim Ducks</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37558"><a href="https://mynhltraderumors.com/top-nhl-prospects/arizona-coyotes/">Arizona Coyotes</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37557"><a href="https://mynhltraderumors.com/top-nhl-prospects/boston-bruins/">Boston Bruins</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37556"><a href="https://mynhltraderumors.com/top-nhl-prospects/buffalo-sabres/">Buffalo Sabres</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37555"><a href="https://mynhltraderumors.com/top-nhl-prospects/calgary-flames/">Calgary Flames</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37575"><a href="https://mynhltraderumors.com/top-nhl-prospects/carolina-hurricanes/">Carolina Hurricanes</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37574"><a href="https://mynhltraderumors.com/top-nhl-prospects/chicago-blackhawks/">Chicago Blackhawks</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37573"><a href="https://mynhltraderumors.com/top-nhl-prospects/colorado-avalanche/">Colorado Avalanche</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37572"><a href="https://mynhltraderumors.com/top-nhl-prospects/columbus-blue-jackets/">Columbus Blue Jackets</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37571"><a href="https://mynhltraderumors.com/top-nhl-prospects/dallas-stars/">Dallas Stars</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37590"><a href="https://mynhltraderumors.com/top-nhl-prospects/detroit-red-wings/">Detroit Red Wings</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37589"><a href="https://mynhltraderumors.com/top-nhl-prospects/edmonton-oilers/">Edmonton Oilers</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37588"><a href="https://mynhltraderumors.com/top-nhl-prospects/florida-panthers/">Florida Panthers</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37587"><a href="https://mynhltraderumors.com/top-nhl-prospects/los-angeles-kings/">Los Angeles Kings</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37586"><a href="https://mynhltraderumors.com/top-nhl-prospects/minnesota-wild/">Minnestota Wild</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37611"><a href="https://mynhltraderumors.com/top-nhl-prospects/montreal-canadiens/">Montreal Canadiens</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37610"><a href="https://mynhltraderumors.com/top-nhl-prospects/nashville-predators/">Nashville Predators</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37607"><a href="https://mynhltraderumors.com/top-nhl-prospects/new-jersey-devils/">New Jersey Devils</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37609"><a href="https://mynhltraderumors.com/top-nhl-prospects/new-york-islanders/">New York Islanders</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37608"><a href="https://mynhltraderumors.com/top-nhl-prospects/new-york-rangers/">New York Rangers</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37627"><a href="https://mynhltraderumors.com/top-nhl-prospects/ottawa-senators/">Ottawa Senators</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37626"><a href="https://mynhltraderumors.com/top-nhl-prospects/philadelphia-flyers/">Philadelphia Flyers</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37625"><a href="https://mynhltraderumors.com/top-nhl-prospects/phoenix-coyotes/">Phoenix Coyotes</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37624"><a href="https://mynhltraderumors.com/top-nhl-prospects/pittsburgh-penguins/">Pittsburgh Penguins</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37646"><a href="https://mynhltraderumors.com/top-nhl-prospects/san-jose-sharks/">San Jose Sharks</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37623"><a href="https://mynhltraderumors.com/top-nhl-prospects/st-louis-blues/">St. Louis Blues</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37643"><a href="https://mynhltraderumors.com/top-nhl-prospects/tampa-bay-lightning/">Tampa Bay Lightning</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37642"><a href="https://mynhltraderumors.com/top-nhl-prospects/toronto-maple-leafs/">Toronto Maple Leafs</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37641"><a href="https://mynhltraderumors.com/top-nhl-prospects/vancouver-canucks/">Vancouver Canucks</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37640"><a href="https://mynhltraderumors.com/top-nhl-prospects/washington-capitals/">Washington Capitals</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37639"><a href="https://mynhltraderumors.com/top-nhl-prospects/winnipeg-jets/">Winnipeg Jets</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37183"><a href="https://mynhltraderumors.com/nhl-rankings/">Rankings</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-43380"><a href="#">Schedules</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43381"><a href="https://mynhltraderumors.com/nhl-schedules/anaheim-ducks-schedule/">Anaheim Ducks</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43382"><a href="https://mynhltraderumors.com/nhl-schedules/arizona-coyotes-schedule/">Arizona Coyotes</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43383"><a href="https://mynhltraderumors.com/nhl-schedules/boston-bruins-schedule/">Boston Bruins</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43384"><a href="https://mynhltraderumors.com/nhl-schedules/buffalo-sabres-schedule/">Buffalo Sabres</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43385"><a href="https://mynhltraderumors.com/nhl-schedules/calgary-flames-schedule/">Calgary Flames</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43386"><a href="https://mynhltraderumors.com/nhl-schedules/carolina-hurricanes-schedule/">Carolina Hurricanes</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43387"><a href="https://mynhltraderumors.com/nhl-schedules/chicago-blackhawks-schedule/">Chicago Blackhawks</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43388"><a href="https://mynhltraderumors.com/nhl-schedules/colorado-avalanche-schedule/">Colorado Avalanche</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43389"><a href="https://mynhltraderumors.com/nhl-schedules/columbus-blue-jackets-schedule/">Columbus Blue Jackets</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43390"><a href="https://mynhltraderumors.com/nhl-schedules/dallas-stars-schedule/">Dallas Stars</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43391"><a href="https://mynhltraderumors.com/nhl-schedules/detroit-red-wings-schedule/">Detroit Red Wings</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43392"><a href="https://mynhltraderumors.com/nhl-schedules/edmonton-oilers-schedule/">Edmonton Oilers</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43393"><a href="https://mynhltraderumors.com/nhl-schedules/florida-panthers-schedule/">Florida Panthers</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43394"><a href="https://mynhltraderumors.com/nhl-schedules/los-angeles-kings-schedule/">Los Angeles Kings</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43395"><a href="https://mynhltraderumors.com/nhl-schedules/minnesota-wild-schedule/">Minnesota Wild</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43396"><a href="https://mynhltraderumors.com/nhl-schedules/new-jersey-devils-schedule/">New Jersey Devils</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43397"><a href="https://mynhltraderumors.com/nhl-schedules/new-york-islanders-schedule/">New York Islanders</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43398"><a href="https://mynhltraderumors.com/nhl-schedules/new-york-rangers-schedule/">New York Rangers</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43399"><a href="https://mynhltraderumors.com/nhl-schedules/ottawa-senators-schedule/">Ottawa Senators</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43400"><a href="https://mynhltraderumors.com/nhl-schedules/philadelphia-flyers-schedule/">Philadelphia Flyers</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43401"><a href="https://mynhltraderumors.com/nhl-schedules/pittsburgh-penguins-schedule/">Pittsburgh Penguins</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43402"><a href="https://mynhltraderumors.com/nhl-schedules/san-jose-sharks-schedule/">San Jose Sharks</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43403"><a href="https://mynhltraderumors.com/nhl-schedules/st-louis-blues-schedule/">St. Louis Blues</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43404"><a href="https://mynhltraderumors.com/nhl-schedules/tampa-bay-lightning-schedule/">Tampa Bay Lightning</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43405"><a href="https://mynhltraderumors.com/nhl-schedules/toronto-maple-leafs-schedule/">Toronto Maple Leafs</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43406"><a href="https://mynhltraderumors.com/nhl-schedules/vancouver-canucks-schedule/">Vancouver Canucks</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43407"><a href="https://mynhltraderumors.com/nhl-schedules/washington-capitals-schedule/">Washington Capitals</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43408"><a href="https://mynhltraderumors.com/nhl-schedules/winnipeg-jets-schedule/">Winnipeg Jets</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-37182"><a href="https://mynhltraderumors.com/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-64539"><a href="https://mynhltraderumors.com/privacy-policy/">Privacy Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64598"><a href="https://mynhltraderumors.com/about/">About</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64538"><a href="https://mynhltraderumors.com/terms-of-service/">Terms of Service</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64597"><a href="https://mynhltraderumors.com/contact/">Contact</a></li>
</ul>
</li>
</ul>			<div class="navbar-dropdown-follow">
				<span class="navbar-dropdown-btn-follow">Follow</span>

				<div class="navbar-dropdown-container  cs-bg-dark">
						<div class="pk-social-links-wrap  pk-social-links-template-columns pk-social-links-template-col-4 pk-social-links-scheme-light pk-social-links-titles-disabled pk-social-links-counts-enabled pk-social-links-labels-disabled pk-social-links-mode-php pk-social-links-mode-rest">
		<div class="pk-social-links-items">
								<div class="pk-social-links-item pk-social-links-facebook " data-id="facebook">
						<a href="https://facebook.com/myNHLtraderumors" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-facebook"></i>
							
															<span class="pk-social-links-count pk-font-secondary">34K</span>
							
													</a>

											</div>
									<div class="pk-social-links-item pk-social-links-twitter " data-id="twitter">
						<a href="https://twitter.com/myNHLTradeRumor" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-twitter"></i>
							
															<span class="pk-social-links-count pk-font-secondary">18K</span>
							
													</a>

											</div>
									<div class="pk-social-links-item pk-social-links-instagram " data-id="instagram">
						<a href="https://www.instagram.com/rankhockey" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-instagram"></i>
							
															<span class="pk-social-links-count pk-font-secondary">31</span>
							
													</a>

											</div>
						</div>
	</div>
					<div class="navbar-subscribe">
									<div class="pk-subscribe-form-wrap pk-subscribe-form-block">
					
					<div class="pk-subscribe-container ">
						<div class="pk-subscribe-data">
							<h3 class="pk-title">Sign Up for Our Newsletter</h3>
															<p class="pk-subscribe-message ">Get breaking NHL News direct to your inbox.</p>
							
							<form method="post" class="subscription">

								<input type="hidden" name="list_id" value="f5fe892712">

								<div class="pk-input-group">
									
									<input type="text" name="EMAIL" class="email form-control" placeholder="Enter your email">

									<button class="pk-subscribe-submit" type="submit">Subscribe</button>
								</div>

								<input type="hidden" name="_wp_http_referer" value="/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/" />							</form>

															<div class="pk-privacy pk-color-secondary">
									<label><input name="pk-privacy" type="checkbox">By checking this box, you confirm that you have read and are agreeing to our terms of use regarding the storage of the data submitted through this form.</label>
								</div>
													</div>
					</div>
				</div>
								</div>
							</div>
			</div>
					<button type="button" class="navbar-toggle-search toggle-search">
			<i class="cs-icon cs-icon-search"></i>
		</button>
		
			</div><!-- .navbar-content -->

		</div><!-- .navbar-container -->

	</div><!-- .navbar-wrap -->

	
<div class="site-search" id="search">
	<div class="cs-container">
		<div class="search-form-wrap">
			
<form role="search" method="get" class="search-form" action="https://mynhltraderumors.com/">
	<label class="sr-only">Search for:</label>
	<div class="cs-input-group">
		<input type="search" value="" name="s" data-swplive="true" data-swpengine="default" data-swpconfig="default" class="search-field" placeholder="Enter your search topic" required>
		<button type="submit" class="search-submit">Search</button>
	</div>
</form>
			<span class="search-close"></span>
		</div>
	</div>
</div>

</nav><!-- .navbar -->

			
		</header><!-- #masthead -->

		
		<section class="cs-custom-content cs-custom-content-site_content-before"><div class="top-leader">
<div id="RTK_sKld"  style="overflow:hidden"></div>
<div id="RTK_hnVK"  style="overflow:hidden"></div>
</div></section>
        <div class="site-content">

            
<section class="entry-header entry-single-header entry-header-standard entry-header-thumbnail">

	
	

	<div class="cs-container">

		
		
					<div class="entry-inline-meta">
							</div>
		
		<h1 class="entry-title">NHL Rumors: A College UFA Goalie &#8230; Pending UFAs Who May Not Be Back</h1>
						<div class="entry-meta-details">
					<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-watch"></i>2 minute read</li></ul>		<div class="pk-share-buttons-wrap pk-share-buttons-layout-default pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-has-total-counts pk-share-buttons-post_header pk-share-buttons-mode-php pk-share-buttons-mode-rest" data-post-id="65848" data-share-url="https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/" >

							<div class="pk-share-buttons-total pk-share-buttons-total-no-count">
												<div class="pk-share-buttons-title pk-font-primary">Total</div>
							<div class="pk-share-buttons-count pk-font-heading">0</div>
							<div class="pk-share-buttons-label pk-font-secondary">Shares</div>
										</div>
				
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-no-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Share</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&text=NHL%20Rumors%3A%20A%20College%20UFA%20Goalie%20%E2%80%A6%20Pending%20UFAs%20Who%20May%20Not%20Be%20Back&via=myNHLTradeRumor&url=https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Tweet</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/&media=https://mynhltraderumors.com/wp-content/uploads/2020/03/USATSI_14121168_168383719_lowres.jpg" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Pin it</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
					</div>
			
		
	</div>

	
</section>

            <div class="site-content-inner">
                                
                <div class="cs-container">

                    
                    <div id="content" class="main-content">

                        

	<div id="primary" class="content-area">

		
		<main id="main" class="site-main">

			
			
				
					
<article id="post-65848" class="post-section post-65848 post type-post status-publish format-standard has-post-thumbnail category-nhl-free-agents category-nhl-rumors tag-corey-perry tag-dallas-stars tag-dan-hamhuis tag-detroit-red-wings tag-jimmy-howard tag-john-lethemon tag-justin-williams tag-mikko-koivu tag-minnesota-wild tag-nashville-predators tag-patrick-marleau tag-pittsburgh-penguins tag-winnipeg-jets">

	<span class="cs-d-none entry-title">NHL Rumors: A College UFA Goalie &#8230; Pending UFAs Who May Not Be Back</span>
	                <div class="post-media">
                    <figure class="wp-caption">
                        <a href="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14121168_168383719_lowres.jpg">
                            <img width="640" height="427" src="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14121168_168383719_lowres.jpg" class="pk-lazyload-disabled wp-post-image" alt="Looking at some pending UFAs who may not be back next seasons" srcset="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14121168_168383719_lowres.jpg 640w, https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14121168_168383719_lowres-300x200.jpg 300w" sizes="(max-width: 640px) 100vw, 640px" />                        </a>
                                                    <figcaption class="wp-caption-text">© Stan Szeto-USA TODAY Sports</figcaption>
                                            </figure>
                </div>
                            <div class="entry-container">
                            <div class="entry-sidebar-wrap">
                    		<div class="entry-post-next cs-d-none cs-d-lg-block">
			<h5 class="title-block">
				Up next			</h5>

			<article>
									<div class="entry-thumbnail">
						<div class="cs-overlay cs-overlay-simple cs-overlay-ratio cs-ratio-landscape cs-bg-dark">
							<div class="cs-overlay-background">
								<img width="200" height="110" src="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_13753968_168383719_lowres-200x110.jpg" class="attachment-csco-intermediate size-csco-intermediate wp-post-image" alt="Could the Calgary Flames make some big changes this offseason?" />							</div>
							<div class="cs-overlay-content">
															</div>
							<a href="https://mynhltraderumors.com/notable-nhl-rumors-from-the-past-week/2020/03/31/" class="cs-overlay-link"></a>
						</div>
					</div>
								<header class="entry-header">
					<h6 class="entry-title"><a href="https://mynhltraderumors.com/notable-nhl-rumors-from-the-past-week/2020/03/31/">Notable NHL Rumors From The Past Week</a></h6>
									</header>
				</div>
		</section>
	                    <div class="entry-sidebar">
                        
<section class="post-section post-sidebar-date">
	<time class="entry-date published" datetime="2020-03-31T11:58:01-04:00"><span class="reader-text published-text">Published on</span> 03/31/2020</time></section>


<section class="post-section post-sidebar-author">

	<h5 class="title-block">
		Author	</h5>

			<div class="author-wrap">
			<div class="author">
				<div class="author-description">
					<h5 class="title-author">
						<span class="fn">
							<a href="https://mynhltraderumors.com/author/markeasson/" rel="author">
								Mark Easson							</a>
						</span>
					</h5>
									</div>
			</div>
		</div>
		
</section>

                    </div>
                </div>
                        
	<div class="entry-content-wrap">

		
		<div class="entry-content">

			<h5 id="a-college-free-agent-goaltender-still-unsigned"><strong>A college free agent goaltender still unsigned</strong></h5>
<p><strong><a href="https://www.tsn.ca/friday-five-nhl-teams-turn-focus-to-top-ncaa-free-agents-1.1453626">Frank Seravalli of TSN</a></strong>: (from earlier this month) There were teams who had been thinking about using a late round pick last year on Michigan State goaltender John Lethemon. The Winnipeg Jets were one of those teams.</p>
<p>There are numerous teams considering signing the free agent goalie &#8211; with six or seven to have shown serious interest earlier this month. He&#8217;ll be looking for the right fit over upfront money.</p>
<h5 id="looking-at-some-pending-ufas-who-may-not-be-back-next-season"><strong>Looking at some pending UFAs who may not be back next season</strong></h5>
<p><a href="https://thehockeynews.com/news/article/which-pending-ufas-may-have-played-their-final-nhl-game"><strong>Steven Ellis of The Hockey News</strong></a>: Looking a few pending unrestricted NHL free agents who could have played their last NHL game.</p><div class="video-embed"><iframe src="/video-embed/?url=http%3A%2F%2Fembed.sendtonews.com%2Fplayer3%2Fembedcode.js%3Ffk%3DiYBTLV6a%26cid%3D7737%26offsetx%3D0%26offsety%3D0%26floatwidth%3D400%26floatposition%3Dbottom-right"></iframe></div>
<p><a href="http://www.hockey-reference.com/players/p/perryco01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Corey Perry</a> &#8211; Dallas Stars &#8211; It has been a difficult season for the 34-year old winger. He signed a one-year deal with the Stars last season after the Anaheim Ducks bought him out. The Stars will be looking to get younger and there may not be much interest in Perry.</p>
<p><a href="http://www.hockey-reference.com/players/k/koivumi01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Mikko Koivu</a> &#8211; Minnesota Wild &#8211; The 37-year old hasn&#8217;t been really interested in playing anywhere. He&#8217;s no longer been playing in a top-six role. May only be back if he takes a one-year deal around $1 million.</p>
<p><a href="http://www.hockey-reference.com/players/h/hamhuda01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Dan Hamhuis</a> &#8211; Nashville Predators &#8211; Has over 1,100 and his role keeps reducing. He has battled injuries and likely not back with the Predators.</p>
<p><a href="http://www.hockey-reference.com/players/h/howarja02.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Jimmy Howard</a> &#8211; Detroit Red Wings &#8211; The 36-year old had a 2-32-2 record this season. He has an injury history and may take a team that is desperate for a backup goalie.</p>
<p><a href="http://www.hockey-reference.com/players/m/marlepa01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Patrick Marleau</a> &#8211; Pittsburgh Penguins &#8211; 1,723 career games and only got to play eight with the Penguins after a trade deadline deal.</p>
<p><a href="http://www.hockey-reference.com/players/w/williju01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Justin Williams</a> &#8211; Carolina Hurricanes &#8211; Took the start of the season off. Recorded 11 points in 20 games once he decided he wanted to play again. The 38-year old doesn&#8217;t have much else to prove and could hang them up for good.</p>
		</div>

        
		 <div id="ml-spotim">
        <div data-spotim-module="community-promo" data-post-id="65848" data-host-url="https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/" data-spot-id="sp_oHhGytg0"></div>
        <div data-spotim-module="recirculation" data-spot-id="sp_oHhGytg0"></div>
        <script async="true" type="text/javascript" src="https://recirculation.spot.im/spot/sp_oHhGytg0"></script>
        <script async
                data-spotim-module="spotim-launcher"
                src="https://launcher.spot.im/spot/sp_oHhGytg0"
                data-post-url="https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/"
                data-article-tags="corey-perry, dallas-stars, dan-hamhuis, detroit-red-wings, jimmy-howard, john-lethemon, justin-williams, mikko-koivu, minnesota-wild, nashville-predators, patrick-marleau, pittsburgh-penguins, winnipeg-jets, nhl-free-agents, nhl-rumors"
                data-post-id="65848"></script>
    </div>
		
		
		
        <script type="text/javascript">
            taboola_container_id = 'taboola-below-article-65848';
            // Create DOM element to contain the widget using above id
        </script>

        <div id="taboola-below-article-65848"></div>

        <script type="text/javascript">
            window._taboola = window._taboola || [];

            _taboola.push({mode:'thumbnails-a', container: taboola_container_id, placement: 'Below Article Thumbnails', target_type: 'mix'});

            _taboola.push({article:'auto', url:'https://mynhltraderumors.com/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/'});
        </script>
	</div>

	            </div>
            </article>

				
			
			
		</main>

		
	</div><!-- .content-area -->


	<aside id="secondary" class="widget-area sidebar-area">
		<div class="sidebar sidebar-1">
						<div class="widget_text widget custom_html-5 widget_custom_html"><h5 class="title-block title-widget">Sponsor</h5><div class="textwidget custom-html-widget"><div id="RTK_WA3G" style="overflow:hidden"></div>
<div id="RTK_SaOo" style="overflow:hidden"></div></div></div><div class="widget powerkit_social_links_widget-2 powerkit_social_links_widget">
		<div class="widget-body">
			<h5 class="title-block title-widget">Social Links</h5>	<div class="pk-social-links-wrap  pk-social-links-template-inline pk-social-links-scheme-light pk-social-links-titles-enabled pk-social-links-counts-enabled pk-social-links-labels-enabled pk-social-links-mode-php pk-social-links-mode-rest">
		<div class="pk-social-links-items">
								<div class="pk-social-links-item pk-social-links-facebook " data-id="facebook">
						<a href="https://facebook.com/myNHLtraderumors" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-facebook"></i>
															<span class="pk-social-links-title pk-font-heading">Facebook</span>
							
															<span class="pk-social-links-count pk-font-secondary">34K</span>
							
															<span class="pk-social-links-label pk-font-secondary">Likes</span>
													</a>

											</div>
									<div class="pk-social-links-item pk-social-links-twitter " data-id="twitter">
						<a href="https://twitter.com/myNHLTradeRumor" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-twitter"></i>
															<span class="pk-social-links-title pk-font-heading">Twitter</span>
							
															<span class="pk-social-links-count pk-font-secondary">18K</span>
							
															<span class="pk-social-links-label pk-font-secondary">Followers</span>
													</a>

											</div>
									<div class="pk-social-links-item pk-social-links-instagram " data-id="instagram">
						<a href="https://www.instagram.com/rankhockey" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-instagram"></i>
															<span class="pk-social-links-title pk-font-heading">Instagram</span>
							
															<span class="pk-social-links-count pk-font-secondary">31</span>
							
															<span class="pk-social-links-label pk-font-secondary">Followers</span>
													</a>

											</div>
						</div>
	</div>
			</div>

		</div><div class="widget_text widget custom_html-3 widget_custom_html"><h5 class="title-block title-widget">Sponsor</h5><div class="textwidget custom-html-widget"><div id="RTK_FVZE" style="overflow:hidden"></div>
<div id="RTK_Z4YU" style="overflow:hidden"></div></div></div>					</div>
		<div class="sidebar sidebar-2"></div>
	</aside><!-- .widget-area -->


                            
                        </div><!-- .main-content -->

                    
                </div><!-- .cs-container -->

                                            </div><!-- .site-content-inner -->

            
        </div><!-- .site-content -->

		
		
<div class="section-footer-posts">

	
		<div class="cs-container">

			<div class="cs-footer-posts-wrap">

				<div class="cs-footer-posts cs-featured-posts cs-featured-type-4">
					
<article class="layout-featured-grid post-65844 post type-post status-publish format-standard has-post-thumbnail category-nhl-free-agents category-nhl-rumors tag-calgary-flames tag-johnny-gaudreau tag-mathew-barzal tag-new-york-islanders tag-new-york-rangers tag-sean-monahan tag-tony-deangelo">

	<div class="post-wrap">

		<div class="post-outer">

			<a class="post-link" href="https://mynhltraderumors.com/notable-nhl-rumors-from-the-past-week/2020/03/31/"></a>

			
							<div class="post-inner entry-thumbnail">
					<div class="cs-overlay cs-overlay-simple cs-overlay-ratio cs-ratio-landscape cs-bg-dark">
						<div class="cs-overlay-background">
							<img width="260" height="140" src="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_13753968_168383719_lowres-260x140.jpg" class="attachment-csco-thumbnail-alternative size-csco-thumbnail-alternative wp-post-image" alt="Could the Calgary Flames make some big changes this offseason?" srcset="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_13753968_168383719_lowres-260x140.jpg 260w, https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_13753968_168383719_lowres-300x160.jpg 300w, https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_13753968_168383719_lowres-560x300.jpg 560w" sizes="(max-width: 260px) 100vw, 260px" />						</div>
						<div class="cs-overlay-content">
							<div class="meta-category"><ul class="post-categories">
	<li><a href="https://mynhltraderumors.com/nhl-free-agents/" rel="category tag">NHL Free Agents</a></li>
	<li><a href="https://mynhltraderumors.com/nhl-rumors/" rel="category tag">NHL Rumors</a></li></ul></div>						</div>
					</div>
				</div>
			
			<div class="post-inner entry-inner entry-data">
				<header class="entry-header">
					<h2 class="entry-title">Notable NHL Rumors From The Past Week</h2>				</header>


				<div class="entry-excerpt">
					Could the Calgary Flames make some big changes this offseason? Islanders would match an&hellip;				</div>

				<ul class="post-meta"><li class="meta-author"><span class="author"><a class="url fn n" href="https://mynhltraderumors.com/author/lylerichardson/" title="View all posts by Lyle Richardson">Lyle Richardson</a></span></li><li class="meta-date">03/31/2020</li><li class="meta-reading-time"><i class="cs-icon cs-icon-watch"></i>3 minute read</li></ul>			</div>

		</div><!-- .post-outer -->

	</div>

</article><!-- #post-65844 -->

<article class="layout-featured-grid post-65846 post type-post status-publish format-standard has-post-thumbnail category-nhl-free-agents category-nhl-news category-nhl-opinion tag-carolina-hurricanes">

	<div class="post-wrap">

		<div class="post-outer">

			<a class="post-link" href="https://mynhltraderumors.com/nhl-free-agents-trade-candidates-carolina-hurricanes/2020/03/31/"></a>

			
							<div class="post-inner entry-thumbnail">
					<div class="cs-overlay cs-overlay-simple cs-overlay-ratio cs-ratio-landscape cs-bg-dark">
						<div class="cs-overlay-background">
							<img width="260" height="140" src="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14061123_168383719_lowres-260x140.jpg" class="attachment-csco-thumbnail-alternative size-csco-thumbnail-alternative wp-post-image" alt="The Carolina Hurricanes have made numerous moves over the past year. They have around $72.3 million already committed to 15 players for next season. Their core is locked up." srcset="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14061123_168383719_lowres-260x140.jpg 260w, https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14061123_168383719_lowres-300x160.jpg 300w, https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_14061123_168383719_lowres-560x300.jpg 560w" sizes="(max-width: 260px) 100vw, 260px" />						</div>
						<div class="cs-overlay-content">
							<div class="meta-category"><ul class="post-categories">
	<li><a href="https://mynhltraderumors.com/nhl-free-agents/" rel="category tag">NHL Free Agents</a></li>
	<li><a href="https://mynhltraderumors.com/nhl-news/" rel="category tag">NHL News</a></li>
	<li><a href="https://mynhltraderumors.com/nhl-opinion/" rel="category tag">NHL Opinion</a></li></ul></div>						</div>
					</div>
				</div>
			
			<div class="post-inner entry-inner entry-data">
				<header class="entry-header">
					<h2 class="entry-title">NHL Free Agents &#038; Trade Candidates &#8211; Carolina Hurricanes</h2>				</header>


				<div class="entry-excerpt">
					The Carolina Hurricanes have made numerous moves over the past year. They have around&hellip;				</div>

				<ul class="post-meta"><li class="meta-author"><span class="author"><a class="url fn n" href="https://mynhltraderumors.com/author/lylerichardson/" title="View all posts by Lyle Richardson">Lyle Richardson</a></span></li><li class="meta-date">03/31/2020</li><li class="meta-reading-time"><i class="cs-icon cs-icon-watch"></i>1 minute read</li></ul>			</div>

		</div><!-- .post-outer -->

	</div>

</article><!-- #post-65846 -->

<article class="layout-featured-grid post-65841 post type-post status-publish format-standard has-post-thumbnail category-nhl-free-agents category-nhl-news tag-anaheim-ducks tag-arizona-coyotes tag-calgary-flames tag-edmonton-oilers-trade-rumors-news-injuries tag-hunter-drew tag-jack-badini tag-los-angeles-kings-trade-rumors-news-injuries tag-michael-chaput tag-san-jose-sharks tag-tyler-madden">

	<div class="post-wrap">

		<div class="post-outer">

			<a class="post-link" href="https://mynhltraderumors.com/nhl-news-oilers-and-flames-lay-off-some-employees-and-some-player-signings/2020/03/31/"></a>

			
							<div class="post-inner entry-thumbnail">
					<div class="cs-overlay cs-overlay-simple cs-overlay-ratio cs-ratio-landscape cs-bg-dark">
						<div class="cs-overlay-background">
							<img width="260" height="140" src="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_13919110_168383719_lowres-260x140.jpg" class="attachment-csco-thumbnail-alternative size-csco-thumbnail-alternative wp-post-image" alt="The Arizona Coyotes re-signed Michael Chaput" srcset="https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_13919110_168383719_lowres-260x140.jpg 260w, https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_13919110_168383719_lowres-300x160.jpg 300w, https://s22929.pcdn.co/wp-content/uploads/2020/03/USATSI_13919110_168383719_lowres-560x300.jpg 560w" sizes="(max-width: 260px) 100vw, 260px" />						</div>
						<div class="cs-overlay-content">
							<div class="meta-category"><ul class="post-categories">
	<li><a href="https://mynhltraderumors.com/nhl-free-agents/" rel="category tag">NHL Free Agents</a></li>
	<li><a href="https://mynhltraderumors.com/nhl-news/" rel="category tag">NHL News</a></li></ul></div>						</div>
					</div>
				</div>
			
			<div class="post-inner entry-inner entry-data">
				<header class="entry-header">
					<h2 class="entry-title">NHL News: Oilers and Flames Lay Off Some Employees, and Some Player Signings</h2>				</header>


				<div class="entry-excerpt">
					The Edmonton Oilers and Calgary Flames temporarily lay off some employees. Player&hellip;				</div>

				<ul class="post-meta"><li class="meta-author"><span class="author"><a class="url fn n" href="https://mynhltraderumors.com/author/markeasson/" title="View all posts by Mark Easson">Mark Easson</a></span></li><li class="meta-date">03/31/2020</li><li class="meta-reading-time"><i class="cs-icon cs-icon-watch"></i>2 minute read</li></ul>			</div>

		</div><!-- .post-outer -->

	</div>

</article><!-- #post-65841 -->

<article class="layout-featured-grid post-65839 post type-post status-publish format-standard has-post-thumbnail category-nhl-free-agents category-nhl-rumors tag-alexander-barabanov tag-chicago-blackhawks-trade-rumors-news-injuries tag-ian-mitchell tag-toronto-maple-leafs-trade-rumors-news-injuries">

	<div class="post-wrap">

		<div class="post-outer">

			<a class="post-link" href="https://mynhltraderumors.com/nhl-rumors-alexander-barabanov-ian-mitchell-and-the-chicago-blackhawks/2020/03/30/"></a>

			
							<div class="post-inner entry-thumbnail">
					<div class="cs-overlay cs-overlay-simple cs-overlay-ratio cs-ratio-landscape cs-bg-dark">
						<div class="cs-overlay-background">
							<img width="260" height="140" src="https://s22929.pcdn.co/wp-content/uploads/2020/03/ian-mitchell-260x140.jpg" class="attachment-csco-thumbnail-alternative size-csco-thumbnail-alternative wp-post-image" alt="The Chicago Blackhawks and Ian Mitchell looking at their options." srcset="https://s22929.pcdn.co/wp-content/uploads/2020/03/ian-mitchell-260x140.jpg 260w, https://s22929.pcdn.co/wp-content/uploads/2020/03/ian-mitchell-300x160.jpg 300w, https://s22929.pcdn.co/wp-content/uploads/2020/03/ian-mitchell-560x300.jpg 560w" sizes="(max-width: 260px) 100vw, 260px" />						</div>
						<div class="cs-overlay-content">
							<div class="meta-category"><ul class="post-categories">
	<li><a href="https://mynhltraderumors.com/nhl-free-agents/" rel="category tag">NHL Free Agents</a></li>
	<li><a href="https://mynhltraderumors.com/nhl-rumors/" rel="category tag">NHL Rumors</a></li></ul></div>						</div>
					</div>
				</div>
			
			<div class="post-inner entry-inner entry-data">
				<header class="entry-header">
					<h2 class="entry-title">NHL Rumors: Alexander Barabanov, Ian Mitchell and the Chicago Blackhawks</h2>				</header>


				<div class="entry-excerpt">
					At least 20 teams showed interest in Alexander Barabanov. The Chicago Blackhawks and&hellip;				</div>

				<ul class="post-meta"><li class="meta-author"><span class="author"><a class="url fn n" href="https://mynhltraderumors.com/author/markeasson/" title="View all posts by Mark Easson">Mark Easson</a></span></li><li class="meta-date">03/30/2020</li><li class="meta-reading-time"><i class="cs-icon cs-icon-watch"></i>2 minute read</li></ul>			</div>

		</div><!-- .post-outer -->

	</div>

</article><!-- #post-65839 -->
				</div>

				
			</div>

		</div>

	
</div>


		
		<footer id="colophon" class="site-footer cs-bg-dark">

			<div class="site-info">

									<div class="footer-aside">
										<div class="pk-subscribe-form-wrap pk-subscribe-form-block">
					
					<div class="pk-subscribe-container ">
						<div class="pk-subscribe-data">
							
															<p class="pk-subscribe-message ">Subscribe to our daily newsletter.</p>
							
							<form method="post" class="subscription">

								<input type="hidden" name="list_id" value="f5fe892712">

								<div class="pk-input-group">
									
									<input type="text" name="EMAIL" class="email form-control" placeholder="Enter your email">

									<button class="pk-subscribe-submit" type="submit">Subscribe</button>
								</div>

								<input type="hidden" name="_wp_http_referer" value="/nhl-rumors-a-college-ufa-goalie-pending-ufas-who-may-not-be-back/2020/03/31/" />							</form>

															<div class="pk-privacy pk-color-secondary">
									<label><input name="pk-privacy" type="checkbox">By checking this box, you confirm that you have read and are agreeing to our terms of use regarding the storage of the data submitted through this form.</label>
								</div>
													</div>
					</div>
				</div>
									</div>
				
				<div class="footer-content">
											<h5 class="site-title footer-title">NHL Rumors</h5>
							<div class="pk-social-links-wrap  pk-social-links-template-nav pk-social-links-scheme-bold pk-social-links-scheme-light-rounded pk-social-links-titles-disabled pk-social-links-counts-enabled pk-social-links-labels-disabled pk-social-links-mode-php pk-social-links-mode-rest">
		<div class="pk-social-links-items">
								<div class="pk-social-links-item pk-social-links-facebook " data-id="facebook">
						<a href="https://facebook.com/myNHLtraderumors" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-facebook"></i>
							
															<span class="pk-social-links-count pk-font-secondary">34K</span>
							
													</a>

											</div>
									<div class="pk-social-links-item pk-social-links-twitter " data-id="twitter">
						<a href="https://twitter.com/myNHLTradeRumor" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-twitter"></i>
							
															<span class="pk-social-links-count pk-font-secondary">18K</span>
							
													</a>

											</div>
									<div class="pk-social-links-item pk-social-links-instagram " data-id="instagram">
						<a href="https://www.instagram.com/rankhockey" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-instagram"></i>
							
															<span class="pk-social-links-count pk-font-secondary">31</span>
							
													</a>

											</div>
						</div>
	</div>
	
					<nav class="navbar-footer"><ul id="menu-footer-menu" class="navbar-nav"><li id="menu-item-64602" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64602"><a href="https://mynhltraderumors.com/about/">About</a></li>
<li id="menu-item-64600" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64600"><a href="https://mynhltraderumors.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-64601" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-64601"><a href="https://mynhltraderumors.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-64599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64599"><a href="https://mynhltraderumors.com/contact/">Contact</a></li>
<li id="menu-item-64603" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-64603"><a href="https://mediumlarge.la">Medium Large, LLC</a></li>
</ul></nav>
											<div class="footer-copyright">
							© 2009-2020 Medium Large Sports Media, LLC. All Rights Reserved. Use of this site constitutes acceptance of our Terms of Use and Privacy Policy.						</div>
										</div>
			</div><!-- .site-info -->

		</footer>

		
	</div><!-- .site-inner -->

	
</div><!-- .site -->



		
		            <script type="text/javascript">

                //jQuery(document).ready(function($) {
                jQuery(document).ready(function ($) {
                    var count = 0;
                    var pathname = window.location.pathname; // Returns path only
                    var url = window.location.href;
                    var pdf;

                    $("a").each(function () {


                        if (($(this).attr('href') !== '#') && ($(this).attr('href') != null)) {

                            var url = $(this).attr('href');

							
                        }

                    }); //each


                });

            </script>

					<a href="#top" class="pk-scroll-to-top">
				<i class="pk-icon pk-icon-up"></i>
			</a>
					<div class="pk-mobile-share-overlay">
							</div>
					<div id="fb-root"></div>
		<script>( function( d, s, id ) {
			var js, fjs = d.getElementsByTagName( s )[0];
			if ( d.getElementById( id ) ) return;
			js = d.createElement( s ); js.id = id;
			js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=233401800329539";
			fjs.parentNode.insertBefore( js, fjs );
		}( document, 'script', 'facebook-jssdk' ) );</script>
					<style type="text/css">
					.searchwp-live-search-results {
						opacity: 0;
						transition: opacity .25s ease-in-out;
						-moz-transition: opacity .25s ease-in-out;
						-webkit-transition: opacity .25s ease-in-out;
						height: 0;
						overflow: hidden;
						z-index: 9999995; /* Exceed SearchWP Modal Search Form overlay. */
						position: absolute;
						display: none;
					}

					.searchwp-live-search-results-showing {
						display: block;
						opacity: 1;
						height: auto;
						overflow: auto;
					}

					.searchwp-live-search-no-results {
						padding: 3em 2em 0;
						text-align: center;
					}

					.searchwp-live-search-no-min-chars:after {
						content: "Continue typing";
						display: block;
						text-align: center;
						padding: 2em 2em 0;
					}
				</style>
			<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/mynhltraderumors.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/basic-elements/public/js/public-powerkit-basic-elements.js?ver=4.0.0'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/justified-gallery/public/js/jquery.justifiedGallery.min.js?ver=2.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var powerkitJG = {"rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/justified-gallery/public/js/public-powerkit-justified-gallery.js?ver=2.1.0'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/lightbox/public/js/jquery.magnific-popup.min.js?ver=2.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var powerkit_lightbox_localize = {"text_previous":"Previous","text_next":"Next","text_close":"Close","text_loading":"Loading","text_counter":"of","single_image_selectors":".entry-content img,.single .post-media img","gallery_selectors":".wp-block-gallery,.gallery","exclude_selectors":"","zoom_icon":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/lightbox/public/js/public-powerkit-lightbox.js?ver=2.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var opt_in = {"ajax_url":"https:\/\/mynhltraderumors.com\/wp-admin\/admin-ajax.php","warning_privacy":"Please confirm that you agree with our policies."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/opt-in-forms/public/js/public-powerkit-opt-in-forms.js?ver=2.1.0'></script>
<script type='text/javascript' async="async" defer="defer" src='//assets.pinterest.com/js/pinit.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var powerkit_pinit_localize = {"image_selectors":".entry-content img","exclude_selectors":".pk-block-author,.pk-featured-categories img,.pk-inline-posts-container img,.pk-instagram-image,.pk-subscribe-image,.pk-block-posts","only_hover":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/pinterest/public/js/public-powerkit-pin-it.js?ver=2.1.0'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/scroll-to-top/public/js/public-powerkit-scroll-to-top.js?ver=2.1.0'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/share-buttons/public/js/public-powerkit-share-buttons.js?ver=2.1.0'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/slider-gallery/public/js/flickity.pkgd.min.js?ver=2.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var powerkit_sg_flickity = {"page_info_sep":" of "};
/* ]]> */
</script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/slider-gallery/public/js/public-powerkit-slider-gallery.js?ver=2.1.0'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/powerkit/modules/table-of-contents/public/js/public-powerkit-table-of-contents.js?ver=2.1.0'></script>
<script type='text/javascript'>
var renderInvisibleReCaptcha = function() {

    for (var i = 0; i < document.forms.length; ++i) {
        var form = document.forms[i];
        var holder = form.querySelector('.inv-recaptcha-holder');

        if (null === holder) continue;
		holder.innerHTML = '';

         (function(frm){
			var cf7SubmitElm = frm.querySelector('.wpcf7-submit');
            var holderId = grecaptcha.render(holder,{
                'sitekey': '', 'size': 'invisible', 'badge' : 'bottomright',
                'callback' : function (recaptchaToken) {
					if((null !== cf7SubmitElm) && (typeof jQuery != 'undefined')){jQuery(frm).submit();grecaptcha.reset(holderId);return;}
					 HTMLFormElement.prototype.submit.call(frm);
                },
                'expired-callback' : function(){grecaptcha.reset(holderId);}
            });

			if(null !== cf7SubmitElm && (typeof jQuery != 'undefined') ){
				jQuery(cf7SubmitElm).off('click').on('click', function(clickEvt){
					clickEvt.preventDefault();
					grecaptcha.execute(holderId);
				});
			}
			else
			{
				frm.onsubmit = function (evt){evt.preventDefault();grecaptcha.execute(holderId);};
			}


        })(form);
    }
};
</script>
<script type='text/javascript' async defer src='https://www.google.com/recaptcha/api.js?onload=renderInvisibleReCaptcha&#038;render=explicit'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/marfeelpress/includes/base/src/resources/js/resizer.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LfpfM8UAAAAAAudmhdyPDK4di-1o5q_OCw4XcDl&#038;ver=3.0'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/themes/spotlight-child/js/scripts.js?ver=1568835825'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/themes/spotlight-child/js/colcade.js?ver=0.2.0'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/themes/spotlight-child/js/ofi.min.js?ver=3.2.3'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/themes/spotlight-child/js/theme.js?ver=1.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var searchwp_live_search_params = [];
searchwp_live_search_params = {"ajaxurl":"https:\/\/mynhltraderumors.com\/wp-admin\/admin-ajax.php","origin_id":65848,"config":{"default":{"engine":"default","input":{"delay":300,"min_chars":3},"results":{"position":"bottom","width":"auto","offset":{"x":0,"y":5}},"spinner":{"lines":12,"length":8,"width":3,"radius":8,"scale":1,"corners":1,"color":"#424242","fadeColor":"transparent","speed":1,"rotate":0,"animation":"searchwp-spinner-line-fade-quick","direction":1,"zIndex":2000000000,"className":"spinner","top":"50%","left":"50%","shadow":"0 0 1px transparent","position":"absolute"}}},"msg_no_config_found":"No valid SearchWP Live Search configuration found!","aria_instructions":"When autocomplete results are available use up and down arrows to review and enter to go to the desired page. Touch device users, explore by touch or with swipe gestures."};;
/* ]]> */
</script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-content/plugins/searchwp-live-ajax-search/assets/javascript/dist/bundle.min.js?ver=1.4.6'></script>
<script type='text/javascript' src='https://s22929.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>
<script type="text/javascript">
( function( grecaptcha, sitekey, actions ) {

	var wpcf7recaptcha = {

		execute: function( action ) {
			grecaptcha.execute(
				sitekey,
				{ action: action }
			).then( function( token ) {
				var forms = document.getElementsByTagName( 'form' );

				for ( var i = 0; i < forms.length; i++ ) {
					var fields = forms[ i ].getElementsByTagName( 'input' );

					for ( var j = 0; j < fields.length; j++ ) {
						var field = fields[ j ];

						if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
							field.setAttribute( 'value', token );
							break;
						}
					}
				}
			} );
		},

		executeOnHomepage: function() {
			wpcf7recaptcha.execute( actions[ 'homepage' ] );
		},

		executeOnContactform: function() {
			wpcf7recaptcha.execute( actions[ 'contactform' ] );
		},

	};

	grecaptcha.ready(
		wpcf7recaptcha.executeOnHomepage
	);

	document.addEventListener( 'change',
		wpcf7recaptcha.executeOnContactform, false
	);

	document.addEventListener( 'wpcf7submit',
		wpcf7recaptcha.executeOnHomepage, false
	);

} )(
	grecaptcha,
	'6LfpfM8UAAAAAAudmhdyPDK4di-1o5q_OCw4XcDl',
	{"homepage":"homepage","contactform":"contactform"}
);
</script>
	<script type="text/javascript">
		"use strict";

		(function($) {

			$( window ).load( function() {

				// Get all links.
				var powerkitSLinksIds = [];

				var powerkitSLinksRestBox = $( '.pk-social-links-mode-rest' );

				// Generate links Ids.
				$( powerkitSLinksRestBox ).each( function( index, wrap ) {

					if ( ! $( wrap ).hasClass( 'pk-social-links-counts-disabled' ) ) {

						$( wrap ).find( '.pk-social-links-item' ).each( function() {
							if ( $( this ).attr( 'data-id' ).length > 0 ) {
								powerkitSLinksIds.push( $( this ).attr( 'data-id' ) );
							}
						});
					}
				});

				// Generate links data.
				var powerkitSLinksData = {};

				if( powerkitSLinksIds.length > 0 ) {
					powerkitSLinksData = { 'ids' : powerkitSLinksIds.join() };
				}

				// Check data.
				if ( ! Object.entries( powerkitSLinksData ).length ) {
					return;
				}

				// Get results by REST API.
				$.ajax({
					type: 'GET',
					url: 'https://mynhltraderumors.com/wp-json/social-counts/v1/get-counts',
					data: powerkitSLinksData,
					beforeSend: function(){

						// Add Loading Class.
						powerkitSLinksRestBox.addClass( 'pk-social-links-loading' );
					},
					success: function( response ) {

						if ( ! $.isEmptyObject( response ) && ! response.hasOwnProperty( 'code' ) ) {

							// SLinks loop.
							$.each( response, function( index, data ) {

								// Find Bsa Item.
								var powerkitSLinksItem = powerkitSLinksRestBox.find( '.pk-social-links-item[data-id="' + index + '"]');

								// Set Class.
								if ( data.hasOwnProperty( 'class' ) ) {
									powerkitSLinksItem.addClass( data.class );
								}

								// Set Count.
								if ( data.hasOwnProperty( 'result' ) && data.result !== null && data.result.hasOwnProperty( 'count' ) ) {

									if ( data.result.count ) {
										// Class Item.
										powerkitSLinksItem.removeClass( 'pk-social-links-no-count' ).addClass( 'pk-social-links-item-count' );

										// Count item.
										powerkitSLinksItem.find( '.pk-social-links-count' ).html( data.result.count );
									}
								} else {
									powerkitSLinksItem.addClass( 'pk-social-links-no-count' );
								}

							});
						}

						// Remove Loading Class.
						powerkitSLinksRestBox.removeClass( 'pk-social-links-loading' );
					},
					error: function() {

						// Remove Loading Class.
						powerkitSLinksRestBox.removeClass( 'pk-social-links-loading' );
					}
				});
			});

		})(jQuery);
	</script>
		<script type="text/javascript">
		"use strict";

		(function($) {

			$( window ).load( function() {

				// Each All Share boxes.
				$( '.pk-share-buttons-mode-rest' ).each( function() {

					var powerkitButtonsIds = [],
						powerkitButtonsBox = $( this );

					// Check Counts.
					if ( ! powerkitButtonsBox.hasClass( 'pk-share-buttons-has-counts' ) && ! powerkitButtonsBox.hasClass( 'pk-share-buttons-has-total-counts' ) ) {
						return;
					}

					powerkitButtonsBox.find( '.pk-share-buttons-item' ).each( function() {
						if ( $( this ).attr( 'data-id' ).length > 0 ) {
							powerkitButtonsIds.push( $( this ).attr( 'data-id' ) );
						}
					});

					// Generate accounts data.
					var powerkitButtonsData = {};

					if( powerkitButtonsIds.length > 0 ) {
						powerkitButtonsData = {
							'ids'     : powerkitButtonsIds.join(),
							'post_id' : powerkitButtonsBox.attr( 'data-post-id' ),
							'url'     : powerkitButtonsBox.attr( 'data-share-url' ),
						};
					}

					// Get results by REST API.
					$.ajax({
						type: 'GET',
						url: 'https://mynhltraderumors.com/wp-json/social-share/v1/get-shares',
						data: powerkitButtonsData,
						beforeSend: function(){

							// Add Loading Class.
							powerkitButtonsBox.addClass( 'pk-share-buttons-loading' );
						},
						success: function( response ) {

							if ( ! $.isEmptyObject( response ) && ! response.hasOwnProperty( 'code' ) ) {

								// Accounts loop.
								$.each( response, function( index, data ) {

									if ( index !== 'total_count' ) {

										// Find Bsa Item.
										var powerkitButtonsItem = powerkitButtonsBox.find( '.pk-share-buttons-item[data-id="' + index + '"]');

										// Set Count.
										if ( data.hasOwnProperty( 'count' ) && data.count  ) {

											powerkitButtonsItem.removeClass( 'pk-share-buttons-no-count' ).addClass( 'pk-share-buttons-item-count' );
											powerkitButtonsItem.find( '.pk-share-buttons-count' ).html( data.count );

										} else {
											powerkitButtonsItem.addClass( 'pk-share-buttons-no-count' );
										}
									}
								});

								if ( powerkitButtonsBox.hasClass( 'pk-share-buttons-has-total-counts' ) && response.hasOwnProperty( 'total_count' ) ) {
									var powerkitButtonsTotalBox = powerkitButtonsBox.find( '.pk-share-buttons-total' );

									if ( response.total_count ) {
										powerkitButtonsTotalBox.find( '.pk-share-buttons-count' ).html( response.total_count );
										powerkitButtonsTotalBox.show().removeClass( 'pk-share-buttons-total-no-count' );
									}
								}
							}

							// Remove Loading Class.
							powerkitButtonsBox.removeClass( 'pk-share-buttons-loading' );
						},
						error: function() {

							// Remove Loading Class.
							powerkitButtonsBox.removeClass( 'pk-share-buttons-loading' );
						}
					});
				});
			});

		})(jQuery);
	</script>
	

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-D5aWmad5UBDrX"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-D5aWmad5UBDrX.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="mynhltraderumors_com",_audins_did=182912;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.mynhltraderumors_com,DomainId.182912" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(a){for(var b=0;b<document.styleSheets.length;b++)if(document.styleSheets[b].href==a)return!0;return!1}var a=function(a,b){for(var d=0;d<b.length;d++){var c=b[d];if(0==c.complete||"undefined"!=typeof c.readyState&&4>c.readyState){var g=c.getAttribute("src")||c.currentSrc;"undefined"!=typeof c.readyState&&0==c.readyState?c.addEventListener("loadstart",function(a){var b=a.getAttribute("src")||a.currentSrc;window.ezorqs(a,b)}):(g=c.getAttribute("src")||c.currentSrc,window.ezorqs(c,
	g));c.addEventListener("load",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)});c.addEventListener("loadeddata",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)});c.addEventListener("error",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)})}}};a("img",document.querySelectorAll("img"));a("video",document.querySelectorAll("video"));a("audio",document.querySelectorAll("audio"));
	(function(a){for(var c=0;c<a.length;c++){var d=a[c];if(("preload"==d.getAttribute("rel")||"stylesheet"==d.getAttribute("rel"))&&null!=d.getAttribute("href")&&b(d.getAttribute("href"))){window.ezorqs(d,d.getAttribute("href"));var e=document.createElement("img");e.onerror=function(a){"undefined"!=typeof a.path&&"undefined"!=typeof a.path[0].currentSrc?window.ezorqe(d,a.path[0].currentSrc):"undefined"!=typeof a.srcElement&&"undefined"!=typeof a.srcElement.href&&window.ezorqe(d,a.srcElement.href)};e.src=
	d.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script></body>
</html>
